Skip to main content
← npm

prismjs

6 known vulnerabilities (5 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
6 · 5 high, 1 medium
Registry
npm

Advisories 6

  • CVE-2024-53382Medium 4.9

    Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly…

    Affected: fixed in 1.30.0.

  • Cross-site Scripting in Prism

    Affected: from 1.14.0, fixed in 1.27.0.

  • Inefficient Regular Expression Complexity in prismjs/prism

    Affected: fixed in 1.25.0.

  • Regular Expression Denial of Service (ReDoS) in Prism

    Affected: fixed in 1.24.0.

  • Regular Expression Denial of Service (ReDoS)

    Affected: fixed in 1.23.0.

  • Cross-Site Scripting in Prism

    Affected: from 1.1.0, fixed in 1.21.0.