Skip to main content
← All vulnerabilities
CVE-2020-15138GHSA-WVHM-4HHF-97X9

Cross-Site Scripting in Prism

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.21.0
None on Exploit-DB, Metasploit or GitHub

Summary

Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the Previewers plugin (>=v1.10.0) or the Previewer: Easing plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • PrismJS prism

    From 1.1.0 · fixed in 1.21.0

  • prismjsnpm

    From 1.1.0 · fixed in 1.21.0

References 3

GitHub · PrismJS/prism

prismjs.com