Skip to main content
← Maven

org.geoserver:gs-main

6 known vulnerabilities (2 high, 3 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
6 · 2 high, 3 medium
Registry
Maven Central

Advisories 6

  • CVE-2025-58175Medium 6.5

    GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution

    Affected: fixed in 2.26.4; from 2.27.0, fixed in 2.27.3.

  • CVE-2024-34696Medium 4.5

    GeoServer's Server Status shows sensitive environmental variables and Java properties

    Affected: from 2.10.0, fixed in 2.24.4; from 2.25.0, fixed in 2.25.1.

  • CVE-2024-23640Medium 4.8

    GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Style Publisher

    Affected: fixed in 2.23.3.

  • GeoServer log file path traversal vulnerability

    Affected: through 2.23.4.

  • GeoServer through 2.18.5 and 2.19.x through 2.19.2 allows SSRF via the option for setting a proxy host.

    Affected: through 2.18.5; from 2.19.0, through 2.19.2.

  • Improper Input Validation in GeoServer

    Affected: from 2.20.0, fixed in 2.20.4; fixed in 2.19.6.