Skip to main content
← All vulnerabilities
CVE-2025-58175GHSA-X4R9-GMW3-HXWW

GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.26.4, 2.27.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • geoserver org.geoserver.web:gs-web-app

    fixed in 2.26.4; From 2.27.0 · fixed in 2.27.3

  • geoserver org.geoserver:gs-main

    fixed in 2.26.4; From 2.27.0 · fixed in 2.27.3

  • org.geoserver.web:gs-web-appMaven

    fixed in 2.26.4

  • org.geoserver:gs-mainMaven

    fixed in 2.26.4

  • org.geoserver:gs-mainMaven

    From 2.27.0 · fixed in 2.27.3

  • org.geoserver.web:gs-web-appMaven

    From 2.27.0 · fixed in 2.27.3

References 3

GitHub · geoserver/geoserver

osgeo-org.atlassian.net