Skip to main content
← Maven

org.apache.geode:geode-core

17 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
17 · 1 medium
Registry
Maven Central

Advisories 17

  • CVE-2022-34870Medium 5.4

    Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application

    Affected: fixed in 1.15.1.

  • Apache Geode deserialization of untrusted data flaw when using REST API on Java 8 or Java 11

    Affected: fixed in 1.15.0.

  • Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11

    Affected: fixed in 1.15.0.

  • Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.

    Affected: fixed in 1.12.16; from 1.13.0, fixed in 1.13.5; from 1.14.0, fixed in 1.14.1.

  • Apache Geode project log file redaction of sensitive information vulnerability

    Affected: fixed in 1.12.5; from 1.13.0, fixed in 1.13.5.

  • When TLS is enabled with ssl-endpoint-identification-enabled set to true, Apache Geode fails to perform hostname verification of the…

    Affected: fixed in 1.10.0.

  • When an Apache Geode server versions 1.0.0 to 1.8.0 is operating in secure mode, a user with write permissions for specific data regions…

    Affected: fixed in 1.9.0.

  • When an Apache Geode server versions 1.0.0 to 1.4.0 is configured with a security manager, a user with DATA:WRITE privileges is allowed to…

    Affected: from 1.0.0, fixed in 1.5.0.

  • In Apache Geode before v1.4.0, the Geode server stores application objects in serialized form.

    Affected: from 1.0.0, fixed in 1.4.0.

  • In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data.

    Affected: from 1.0.0, fixed in 1.4.0.

  • When an Apache Geode cluster before v1.4.0 is operating in secure mode, the Geode configuration service does not properly authorize…

    Affected: from 1.0.0, fixed in 1.4.0.

  • When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster…

    Affected: from 1.0.0, fixed in 1.3.0.

  • When an Apache Geode cluster before v1.3.0 is operating in secure mode, a user with read access to specific regions within a Geode cluster…

    Affected: from 1.0.0, fixed in 1.3.0.

  • When an Apache Geode cluster before v1.3.0 is operating in secure mode and an authenticated user connects to a Geode cluster using the…

    Affected: from 1.0.0, fixed in 1.3.0.

  • When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode…

    Affected: from 1.0.0, fixed in 1.2.1.

Show all 17 advisoriesShow fewer advisories
  • When a cluster is operating in secure mode, a user with read privileges for specific data regions can use the gfsh command line utility to…

    Affected: from 1.0.0, fixed in 1.2.1.

  • Apache Geode before 1.1.1, when a cluster has enabled security by setting the security-manager property, allows remote authenticated users…

    Affected: from 1.1.0, fixed in 1.1.1.