Skip to main content
← All vulnerabilities
CVE-2022-37021GHSA-Q4Q3-R45F-7GWG

Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.12.16, 1.13.5, 1.14.1
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Geode

    through 1.12.5

  • org.apache.geode:geode-coreMaven

    fixed in 1.12.16

  • org.apache.geode:geode-coreMaven

    From 1.13.0 · fixed in 1.13.5

  • org.apache.geode:geode-coreMaven

    From 1.14.0 · fixed in 1.14.1

References 1

lists.apache.org