Skip to main content
← Maven

org.apache.flume.flume-ng-sources:flume-jms-source

3 known vulnerabilities (1 critical), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3 · 1 critical
Registry
Maven Central

Advisories 3

  • CVE-2022-42468Critical 9.8

    Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource

    Affected: fixed in 1.11.0.

  • Improper Input Validation (JNDI Injection) in JMSMessageConsumer

    Affected: from 1.4.0, fixed in 1.10.1.

  • Apache Flume vulnerable to a JNDI RCE in JMSSource

    Affected: from 1.4.0, fixed in 1.10.0.