Skip to main content
← All vulnerabilities
CVE-2022-34916GHSA-H9MH-MGPV-GQMV

Improper Input Validation (JNDI Injection) in JMSMessageConsumer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.11.0, 1.10.1
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Flume

    From flume-jms-source · fixed in 1.11.0

  • org.apache.flume.flume-ng-sources:flume-jms-sourceMaven

    From 1.4.0 · fixed in 1.10.1

References 2

issues.apache.org

lists.apache.org