Skip to main content
← Maven

io.jenkins.plugins:warnings-ng

7 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
7
Registry
Maven Central

Advisories 7

  • Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with…

    Affected: from 10.5.0, fixed in 10.5.1; fixed in 10.4.1.

  • Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing…

    Affected: from 9.8.0, fixed in 9.10.3; from 9.6.0, fixed in 9.7.1; from 9.1.0, fixed in 9.5.2; fixed in 9.0.2.

  • Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation…

    Affected: fixed in 8.5.0.

  • A cross-site request forgery vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attackers to reset warning counts for…

    Affected: fixed in 5.1.0.

  • A cross-site scripting vulnerability in Jenkins Warnings NG Plugin 5.0.0 and earlier allowed attacker with Job/Configure permission to…

    Affected: fixed in 5.1.0.

  • A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in…

    Affected: fixed in 2.0.0.

  • A cross-site request forgery vulnerability exists in Jenkins Warnings Next Generation Plugin 2.1.1 and earlier in…

    Affected: through 2.1.1.