Skip to main content
← All vulnerabilities
CVE-2022-23107GHSA-RVH4-G2RJ-HR9C

Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attacke

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.10.3, 9.7.1, 9.5.2, 9.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins Warnings Next Generation Plugin 9.10.2 and earlier does not restrict the name of a file when configuring custom ID, allowing attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Jenkins project Jenkins Warnings Next Generation Plugin

    through 9.10.2

  • io.jenkins.plugins:warnings-ngMaven

    From 9.8.0 · fixed in 9.10.3

  • io.jenkins.plugins:warnings-ngMaven

    From 9.6.0 · fixed in 9.7.1

  • io.jenkins.plugins:warnings-ngMaven

    From 9.1.0 · fixed in 9.5.2

  • io.jenkins.plugins:warnings-ngMaven

    fixed in 9.0.2

References 2

jenkins.io

openwall.com