- Latest release
- v4.3.0+incompatible (Sep 30, 2026): affected by CVE-2022-38871
- Newest unaffected release
- Every release is affected by at least one advisory
- Advisories
- 6 · 1 critical, 1 high, 1 medium
- Releases
- 63 since v3.0.1+incompatible (Apr 27, 2020)
- Registry
- pkg.go.dev
- Releases read
- Nov 8, 2026
Version timeline
- CVE-2026-55068Affects v3.0.1+incompatible to v4.2.2-0.20260408094255-766d2a89c263+incompatible (v4.2.2+incompatible is outside it)
- CVE-2026-53551Affects v3.0.1+incompatible to v4.2.2-0.20260408094255-766d2a89c263+incompatible (v4.2.2+incompatible is outside it)
- CVE-2023-47025Affects v3.0.1+incompatible to v3.3.0+incompatible (v3.4.0+incompatible is outside it)
- CVE-2023-47345Affects v3.0.1+incompatible to v3.3.0+incompatible (v3.4.0+incompatible is outside it)
- CVE-2022-38871Affects v3.0.1+incompatible to v4.3.0+incompatible (through the newest release)
- CVE-2022-43677Affects v3.0.1+incompatible to v3.2.1+incompatible (v3.2.2-0.20230313125551-78b21b21ab8e+incompatible is outside it)
Advisories 6
- CVE-2026-55068Critical 9.3
free5GC: NRF nnrf-nfm lacks NF Profile input validation — enables NF Registration Poisoning with arbitrary service endpoints
Affected: fixed in 4.2.2; fixed in 4.2.2+incompatible.
Fixed in v4.2.2+incompatible (released Apr 21, 2026, 129 days before disclosure).
The latest release, v4.3.0+incompatible, is not affected.
- CVE-2026-53551Medium 6.9
free5GC AUSF: null byte injection in supiOrSuci causes HTTP 500 internal service failure
Affected: fixed in 4.2.2; fixed in 4.2.2+incompatible.
Fixed in v4.2.2+incompatible (released Apr 21, 2026, 101 days before disclosure).
The latest release, v4.3.0+incompatible, is not affected.
- CVE-2023-47025Unrated
An issue in Free5gc v.3.3.0 allows a local attacker to cause a denial of service via the free5gc-compose component.
Affected: through 3.3.0.
Fixed in v3.4.0+incompatible (released Feb 16, 2024, 92 days after disclosure), the first release outside every affected range (no listed fixed version clears them all).
The latest release, v4.3.0+incompatible, is not affected.
- CVE-2023-47345Unrated
Buffer Overflow vulnerability in free5gc 3.3.0 allows attackers to cause a denial of service via crafted PFCP message with malformed PFCP…
Affected: through 3.3.0.
Fixed in v3.4.0+incompatible (released Feb 16, 2024, 93 days after disclosure), the first release outside every affected range (no listed fixed version clears them all).
The latest release, v4.3.0+incompatible, is not affected.
- CVE-2022-38871High 7.5
In Free5gc v3.0.5, the AMF breaks due to malformed NAS messages.
Affected: all versions.
No fix released. The latest release, v4.3.0+incompatible, is still affected.
- CVE-2022-43677Unrated
In free5GC 3.2.1, a malformed NGAP message can crash the AMF and NGAP decoders via an index-out-of-range panic in aper.GetBitString.
Affected: through 3.2.1.
Fixed in v3.3.0+incompatible (released Jun 8, 2023, 227 days after disclosure), the first release outside every affected range (no listed fixed version clears them all).
The latest release, v4.3.0+incompatible, is not affected.