- Exploited
- No known exploitation
- Fix
- Fixed in 5.6.4
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.6.4.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- The rating the maker of the software gives it. Shown when it differs from the CVSS level.What do these mean? →
- Low (ghsa)
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The devalue library, used in Svelte projects, can produce objects from `devalue.parse` and `devalue.unflatten` that carry an own `__proto__` property. This is not a vulnerability in itself, but downstream code that merges those objects unsafely (for example with `Object.assign`) can be tricked into prototype pollution, which an attacker could exploit only if the application handles that data this way.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
In some circumstances, devalue.parse and devalue.unflatten could emit objects with __proto__ own properties. This in and of itself is not a security vulnerability (and is possible with, for example, JSON.parse as well), but it can result in prototype injection if _downstream_ code handles it incorrectly:
const result = devalue.parse(/* input creating an object with a __proto__ property */);
const target = {};
Object.assign(target, result); // target's prototype is now pollutedcve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach20/20devalue: 24.5M downloads a week
- Severity1/10Rated low by ghsa
- No patch0/5No signal
What would change the score
- Would score about 76 if added to CISA KEV
- Would score about 71 if CISA's SSVC rates exploitation active
- Would score about 43 if advisories confirm default setups are exposed
Impact
What to do
Upgrade to a fixed version: 5.6.4.
Timeline
- Advisory published106 days
- Record last updated
Affected versions
- devaluenpm
From 4.0.0 · fixed in 5.6.4
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about GHSA-MWV9-GP5H-FRR4
Is GHSA-MWV9-GP5H-FRR4 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by GHSA-MWV9-GP5H-FRR4?
devalue (npm): from 4.0.0 before 5.6.4.Source: cve.now feed data
How do I fix GHSA-MWV9-GP5H-FRR4?
Upgrade to a fixed version: 5.6.4.Source: cve.now feed data