Skip to main content
← Vulnerabilities

devalue: Repeated primitive strings cause quadratic expansion in uneval

Exploited
No known exploitation
Fix
Fixed in 5.9.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.9.3.

Published
Last modified
27/100 · provisional
High (ghsa)
None on Exploit-DB, Metasploit or GitHub

Summary

The devalue library is affected: under very constrained circumstances, data that was parsed and then passed to its uneval function can turn a small payload into a very large serialized string.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Under very constrained circumstances, data that was parsed and then passed to uneval could turn a small payload into a very large serialized string.

cve.now Index

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. No advisory context yet
  • Reach20/20devalue: 24.5M downloads a week
  • Severity7/10Rated high by ghsa
  • No patch0/5No signal

What would change the score

  • Would score about 82 if added to CISA KEV
  • Would score about 77 if CISA's SSVC rates exploitation active
  • Would score about 49 if advisories confirm default setups are exposed

Impact

  • Widely used

    devalue has 24.5m weekly downloads.Source: npmjs.com

    414 packages depend on devalue.Source: deps.dev

What to do

  • Upgrade to a fixed version: 5.9.3.

Timeline

  1. Advisory published
  2. Record last updated

Affected versions

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about GHSA-MCM9-63F2-9J32

Is GHSA-MCM9-63F2-9J32 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by GHSA-MCM9-63F2-9J32?

devalue (npm): before 5.9.3.Source: cve.now feed data

How do I fix GHSA-MCM9-63F2-9J32?

Upgrade to a fixed version: 5.9.3.Source: cve.now feed data