Skip to main content
← Vulnerabilities

devalue: Residual sparse-array CPU amplification in uneval

Exploited
No known exploitation
Fix
Fixed in 5.9.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.9.3.

Published
Last modified
24/100 · provisional
Medium (ghsa)
None on Exploit-DB, Metasploit or GitHub

Summary

The devalue library, which serializes JavaScript values, can be made to block the event loop when its `uneval` function processes a sparse array with a very large declared length. Reaching this requires an application that passes attacker-influenced sparse values to `uneval`, and the description notes that it is very difficult to exploit because attackers rarely control how such arrays are created.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

uneval performs synchronous work proportional to a sparse array's declared length. An application that passes attacker-influenced sparse values to uneval can suffer event-loop blocking. Since attacker-controlled creation of sparse arrays is so difficult, this vulnerability is very difficult to exploit.

cve.now Index

24Pcve.now Index 24 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. No advisory context yet
  • Reach20/20devalue: 24.5M downloads a week
  • Severity4/10Rated medium by ghsa
  • No patch0/5No signal

What would change the score

  • Would score about 79 if added to CISA KEV
  • Would score about 74 if CISA's SSVC rates exploitation active
  • Would score about 46 if advisories confirm default setups are exposed

Impact

  • Widely used

    devalue has 24.5m weekly downloads.Source: npmjs.com

    414 packages depend on devalue.Source: deps.dev

What to do

  • Upgrade to a fixed version: 5.9.3.

Timeline

  1. Advisory published
  2. Record last updated

Affected versions

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about GHSA-HX4R-W6WJ-J8FG

Is GHSA-HX4R-W6WJ-J8FG being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by GHSA-HX4R-W6WJ-J8FG?

devalue (npm): before 5.9.3.Source: cve.now feed data

How do I fix GHSA-HX4R-W6WJ-J8FG?

Upgrade to a fixed version: 5.9.3.Source: cve.now feed data