- Exploited
- No known exploitation
- Fix
- Fixed in 5.6.3
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.6.3.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- The rating the maker of the software gives it. Shown when it differs from the CVSS level.What do these mean? →
- Low (ghsa)
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The devalue library, a JavaScript serialization package, is affected by a flaw where serializing sparse arrays with `uneval` or `stringify` can exhaust CPU and memory, causing a denial of service on a server. Exploiting it is considered extremely difficult in practice, because an attacker would first need to get a sparse array into the server, which mainstream wire formats do not allow.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
Under certain circumstances, serializing sparse arrays using uneval or stringify could cause CPU and/or memory exhaustion. When this occurs on the server, it results in a DoS. This is extremely difficult to take advantage of in practice, as an attacker would have to manage to create a sparse array on the server — which is impossible in every mainstream wire format — and then that sparse array would have to be run through uneval or stringify.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach20/20devalue: 24.5M downloads a week
- Severity1/10Rated low by ghsa
- No patch0/5No signal
What would change the score
- Would score about 76 if added to CISA KEV
- Would score about 71 if CISA's SSVC rates exploitation active
- Would score about 43 if advisories confirm default setups are exposed
Impact
What to do
Upgrade to a fixed version: 5.6.3.
Timeline
- Advisory published3 days
- Record last updated
Affected versions
- devaluenpm
fixed in 5.6.3
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about GHSA-33HQ-FVWR-56PM
Is GHSA-33HQ-FVWR-56PM being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by GHSA-33HQ-FVWR-56PM?
devalue (npm): before 5.6.3.Source: cve.now feed data
How do I fix GHSA-33HQ-FVWR-56PM?
Upgrade to a fixed version: 5.6.3.Source: cve.now feed data