pid_namespace: prevent TIF_NOTIFY_SIGNAL from interrupting the reaper
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 6.1.191, 6.6.161, 5.11, 5.16, 6.10
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 6.1.191, 6.6.161, 5.11, 5.16, 6.10.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure?/25Exposure: unknown (data gap). No advisory context yet
- Reach20/20Affects Linux kernel (software on nearly every server, desktop or phone)
- Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
- No patch0/5No signal
What would change the score
- Would score about 75 if added to CISA KEV
- Would score about 70 if CISA's SSVC rates exploitation active
- Would score about 42 if advisories confirm default setups are exposed
CVE-2026-99244 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Linux; fixed in 6.1.191, 6.6.161, 5.11 and 2 more.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 20/100 · provisional
- Fix
- Fixed in 6.1.191, 6.6.161, 5.11, 5.16, 6.10
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The vulnerability affects the Linux kernel's PID namespace handling, specifically the code that reaps processes when a PID namespace is torn down. A signal flag that can be raised repeatedly (such as during livepatching) can interrupt the reaper, causing it to busy-wait and consume CPU rather than sleep.
Read the original description
In the Linux kernel, the following vulnerability has been resolved: pid_namespace: prevent TIF_NOTIFY_SIGNAL from interrupting the reaper Since commit 7fea700e04bd ("zap_pid_ns_processes: clear TIF_NOTIFY_SIGNAL along with TIF_SIGPENDING") zap_pid_ns_processes() clears TIF_NOTIFY_SIGNAL before every kernel_wait4() call. Otherwise kernel_wait4() doesn't sleep and returns -ERESTARTSYS if signal_pending() is true and the reaper busy-waits. But clearing TIF_NOTIFY_SIGNAL doesn't fix it. It can get raised again. For example, klp_send_signals() sets it raw against any task that hasn't transitioned yet. And it keeps sending it until the livepatch finishes. The sleep loop waiting for pid_allocated to drop has the same problem and it doesn't even clear anything. So a schedule() in TASK_INTERRUPTIBLE returns immediately. Use a no_notify_signal guard. signal_pending() will ignore TIF_NOTIFY_SIGNAL and the pid namespace reaper sleeps until a child exits or free_pid() wakes it.
What to do
Upgrade to a fixed version: 6.1.191, 6.6.161, 5.11, 5.16, 6.10.
Timeline
- CVE published
- First seen by cve.now
- Record last updated
Affected versions
- Linux Linux
From 6.1.95 · fixed in 6.1.191; From 6.6.35 · fixed in 6.6.161; From 5.10.221 · fixed in 5.11; From 5.15.162 · fixed in 5.16; From 6.9.6 · fixed in 6.10
- Linux Linux
6.10
Evidence 7
- Link
- Link
- Link
- Link
- Link
Show all 7 sourcesShow fewer sources
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-99244
Is CVE-2026-99244 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-99244?
Linux: from 6.1.95 before 6.1.191; from 6.6.35 before 6.6.161; from 5.10.221 before 5.11; from 5.15.162 before 5.16; from 6.9.6 before 6.10. Linux: version 6.10.Source: cve.now feed data
How do I fix CVE-2026-99244?
Upgrade to a fixed version: 6.1.191, 6.6.161, 5.11, 5.16, 6.10.Source: cve.now feed data