Xray Audit - Moderately critical - Access bypass - SA-CONTRIB-2026-206
Drupal's Xray Audit module before 1.6.3, from 2.0.0 to before 2.0.4, and from 3.0.0 to before 3.1.1 is affected. Each branch has a fixed release, and 3.1.1 is the fix for the 3.x line.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 1.6.3, 2.0.4, 3.1.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Missing Authorization vulnerability in Drupal Xray Audit allows Forceful Browsing. This issue affects Xray Audit versions: from 0.0.0 to 1.6.3, from 2.0.0 to 2.0.4, from 3.0.0 to 3.1.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Drupal Xray Audit
From 0.0.0 · fixed in 1.6.3; From 2.0.0 · fixed in 2.0.4; From 3.0.0 · fixed in 3.1.1
References 1
drupal.org
Questions about CVE-2026-96389
What does this mean?
Rendering an entity through the display-mode example route can let a user view unpublished or otherwise access-restricted content. Field-level access is still enforced, so access-restricted fields such as email or password hash are not disclosed.Source: drupal.org
Am I affected, and how do I check?
Affected versions are Xray Audit before 1.6.3, from 2.0.0 to before 2.0.4, and from 3.0.0 to before 3.1.1. Exposure occurs only when an entity is rendered through the display-mode example route, so check the installed Xray Audit version and whether that route is in use.Source: drupal.org
What should I do about it?
Upgrade to the fixed release for your branch: 1.6.3, 2.0.4, or 3.1.1. The advisory says that if you use Xray Audit 3.1.x, you should upgrade to 3.1.1.Source: drupal.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data