node-opcua: Namespace-Level RBAC Fail-Open - Anonymous Write/Call Bypass via Unbound `DefaultRolePermissions
Affects node-opcua 2.42.0 up to 2.180.0 where a namespace default policy is set with setDefaultRolePermissions, which enforcement silently ignores. Fixed in 2.180.0. No vendor rating is given, so CVSS 9.1 is the only severity stated.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.180.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. A namespace default policy was declared (via setDefaultRolePermissions) and was silently ignored by enforcement; the bypass requires a declared namespace default.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.1/10CVSS 9.1
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
CVE-2026-95860 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.1 (critical) and affects node-opcua; fixed in 2.180.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 21/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.180.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
node-opcua, an OPC UA implementation for Node.js and TypeScript, is affected in versions from 2.42.0 up to (but not including) 2.180.0. The flaw lets an anonymous network client write variables or call methods that an operator meant to restrict through a namespace-level default permission, bypassing intended access control on servers that rely on that inheritance.
Read the original description
node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. SessionContext.getApplicableRolePermissions reads a missing or null DefaultRolePermissions metadata value instead of the configured namespace field, and the null result is treated permissively. An anonymous network client can consequently write variables with CurrentWrite access or call bound methods when an operator configured a restrictive namespace default and relied on inheritance. Servers with no declared policy, nodes with explicit per-node permissions, and correctly bound programmatic namespace metadata are outside the authorization-bypass case. This issue is fixed in version 2.180.0.
What to do
Check whether your setup matches what the bug needs.
A namespace default policy was declared (via setDefaultRolePermissions) and was silently ignored by enforcement; the bypass requires a declared namespace default.Upgrade to a fixed version: 2.180.0.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- node-opcua node-opcua
From 2.42.0 · fixed in 2.180.0
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-95860
Is CVE-2026-95860 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A namespace default policy set with setDefaultRolePermissions() is accepted without error but never enforced. Anonymous clients can then write to and call methods in that namespace even though the policy was meant to block them.Source: github.com
Which versions are affected by CVE-2026-95860?
node-opcua: from 2.42.0 before 2.180.0.Source: cve.now feed data
Am I affected, and how do I check?
Versions from 2.42.0 up to but not including 2.180.0 are in the affected range. To check an installed copy, run npm ls node-opcua in the project, and search the code for setDefaultRolePermissions to see whether a namespace default policy is declared.Source: github.com
How do I fix CVE-2026-95860?
Upgrade node-opcua to 2.180.0, which is the listed fixed version.Source: github.com