Happyforms Pro <= 1.38.9 - Unauthenticated Stored Cross-Site Scripting via 'happyforms_client_referer' Parameter
Affects Happyforms Pro 1.38.9 and earlier, through the referral link. Fixed in 1.38.10.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.38.10
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.38.10.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 24/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Happyforms Pro plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'happyforms_client_referer' parameter in all versions up to, and including, 1.38.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
cve.now Index
- Exploitation0/40No signal
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.2/10CVSS 7.2
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
- Would score about 29 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.38.10.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Happyforms Happyforms Pro
through 1.38.9
Evidence 3
- Link
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-93766
Is CVE-2026-93766 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The referral link lets an unauthenticated attacker store scripts that run in the browser of a user who opens an injected page. This is a stored cross-site scripting flaw.Source: happyforms.io
Which versions are affected by CVE-2026-93766?
Happyforms Pro: through 1.38.9.Source: cve.now feed data
Am I affected, and how do I check?
Happyforms Pro versions up to and including 1.38.9 are affected. Check the installed Happyforms Pro version to see whether it falls in that range.Source: happyforms.io
How do I fix CVE-2026-93766?
Upgrade Happyforms Pro to version 1.38.10, which includes the fix.Source: happyforms.io