Skip to main content
← All vulnerabilities
CVE-2026-93577BIT-GITLAB-2026-93577

Integer Overflow or Wraparound in GitLab

Affects GitLab CE/EE 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 when a specially crafted regular expression is compiled in a CI/CD configuration. Fixed in 19.2.7, 19.3.3, and 19.4.1.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 19.2.7, 19.3.3, 19.4.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

GitLab Community Edition and Enterprise Edition are affected by this vulnerability. An authenticated user could potentially run arbitrary code on the GitLab server by submitting a specially crafted regular expression in a CI/CD configuration.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • GitLab GitLab

    From 19.2 · fixed in 19.2.7; From 19.3 · fixed in 19.3.3; From 19.4 · fixed in 19.4.1

  • gitlabBitnami

    From 19.2.0 · fixed in 19.2.7; From 19.3.0 · fixed in 19.3.3; From 19.4.0 · fixed in 19.4.1

References 3

gitlab.com

hackerone.com

docs.gitlab.com

FAQ

Questions about CVE-2026-93577

What does this mean?

A integer overflow occurs when GitLab compiles a specially crafted regular expression in a CI/CD configuration. The advisory says this could let an authenticated user execute arbitrary code on the GitLab server.Source: docs.gitlab.com

Am I affected, and how do I check?

GitLab CE and EE versions 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 are covered. The setup involves a CI/CD configuration that compiles a regular expression. Compare the installed GitLab version against these ranges.Source: docs.gitlab.com

What should I do about it?

Upgrade to 19.2.7, 19.3.3, or 19.4.1, matching the release line in use.Source: docs.gitlab.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data