Skip to main content
← Vulnerabilities

Quest Foglight for Databases EncryptionUtil Hardcoded Encyption Key Local Privilege Escalation Vulnerability

Affects Quest Foglight for Databases with no version range given; an attacker needs low-privileged code execution first. Fixed in Foglight 8.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.8HighCNA
Exploited
No known exploitation
Fix
Fixed in Foglight 8.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Attacker must already be able to execute low-privileged code on the target system

13Pcve.now Index 13 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure5/25Specific setups only
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.8/10CVSS 7.8
  • No patch0/5No signal

What would change the score

  • Would score about 63 if added to CISA KEV
  • Would score about 58 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

CVE-2026-92199 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.8 (high) and affects Foglight for Databases; fixed in Foglight 8.3.

Published
Last modified
Published
Not listed in CISA KEV
13/100 · provisional
Specific setups only
Fix
Fixed in Foglight 8.3
None on Exploit-DB, Metasploit or GitHub

Summary

Quest Foglight for Databases is affected by this vulnerability, which allows a local attacker who already has low-privileged code execution on the system to gain higher privileges, including running code as SYSTEM. The flaw stems from a hard-coded cryptographic key used in the software's encryption utility, which undermines the protection of encrypted data.

Read the original description

Quest Foglight for Databases EncryptionUtil Hardcoded Encyption Key Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of Quest Foglight for Databases. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within the symmetricDecrypt method. The issue results from the use of a hard-coded cryptographic key. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of SYSTEM. Was ZDI-CAN-29967.

What to do

  • Check whether your setup matches what the bug needs.

    Attacker must already be able to execute low-privileged code on the target system
  • Upgrade to a fixed version: Foglight 8.3.

Timeline

  1. CVE published1 day
  2. First seen by cve.now

Affected versions

  • Quest Foglight for Databases

    8.2.0

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-92199

Is CVE-2026-92199 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The EncryptionUtil component uses a hardcoded encryption key. An attacker who can already run low-privileged code on the system can use this to escalate privileges and run arbitrary code as SYSTEM.Source: zerodayinitiative.com

Which versions are affected by CVE-2026-92199?

Foglight for Databases: version 8.2.0.Source: cve.now feed data

Am I affected, and how do I check?

The advisory does not list specific affected version ranges for Quest Foglight for Databases. Check the installed Foglight version in the product's about or version information and compare it with the advisory.Source: zerodayinitiative.com

How do I fix CVE-2026-92199?

Upgrade Foglight for Databases to version 8.3 or later, which contains the fix.Source: zerodayinitiative.com