Skip to main content
← Vulnerabilities

Quest Foglight for Databases unzipFile Directory Traversal Remote Code Execution Vulnerability

Quest Foglight for Databases is affected, and the advisory gives no version range beyond the fix in Foglight 8.3. No vendor rating is given, so only the CVSS score of 8.8 (high) applies. Fixed in Foglight 8.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in Foglight 8.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affects Quest Foglight for Databases; the advisory does not state any specific version range beyond the fix in Foglight 8.3.

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.8/10CVSS 8.8
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-92197 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Foglight for Databases; fixed in Foglight 8.3.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in Foglight 8.3
None on Exploit-DB, Metasploit or GitHub

Summary

Quest Foglight for Databases is affected by this vulnerability, which allows an authenticated remote attacker to run arbitrary code with SYSTEM privileges by abusing a path validation flaw in its file unzipping function. Successful exploitation would give an attacker full control over the affected server.

Read the original description

Quest Foglight for Databases unzipFile Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Quest Foglight for Databases. Authentication is required to exploit this vulnerability. The specific flaw exists within the unzipFile method. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-29901.

What to do

  • Check whether your setup matches what the bug needs.

    Affects Quest Foglight for Databases; the advisory does not state any specific version range beyond the fix in Foglight 8.3.
  • Upgrade to a fixed version: Foglight 8.3.

Timeline

  1. CVE published1 day
  2. First seen by cve.now

Affected versions

  • Quest Foglight for Databases

    8.2.0

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-92197

Is CVE-2026-92197 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The unzipFile function in Quest Foglight for Databases has a directory traversal flaw, so a crafted zip file can lead to arbitrary code execution in the context of SYSTEM.Source: zerodayinitiative.com

Which versions are affected by CVE-2026-92197?

Foglight for Databases: version 8.2.0.Source: cve.now feed data

Am I affected, and how do I check?

The advisory does not state a version range beyond the fix in Foglight 8.3, so check the installed Foglight for Databases version against that release. Compare the installed version in the product's own information screen.Source: zerodayinitiative.com

How do I fix CVE-2026-92197?

Upgrade Foglight for Databases to version 8.3 or later, which is the fixed release named in the advisory.Source: zerodayinitiative.com