Quest Foglight for Databases paFnUploadFileAndCreateInfo Directory Traversal Remote Code Execution Vulnerability
Affects installations of Quest Foglight for Databases, which carry a CVSS score of 8.8. The fix is in Foglight 8.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in Foglight 8.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affected installations of Quest Foglight for Databases
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.8/10CVSS 8.8
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
CVE-2026-92186 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Foglight for Databases; fixed in Foglight 8.3.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in Foglight 8.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Quest Foglight for Databases is affected by this vulnerability, which allows an authenticated remote attacker to abuse a flaw in its file upload functionality to traverse directories and run arbitrary code with SYSTEM privileges. Successful exploitation could give the attacker full control over the affected server.
Read the original description
Quest Foglight for Databases paFnUploadFileAndCreateInfo Directory Traversal Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Quest Foglight for Databases. Authentication is required to exploit this vulnerability. The specific flaw exists within the paFnUploadFileAndCreateInfo script. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-29038.
What to do
Check whether your setup matches what the bug needs.
Affected installations of Quest Foglight for DatabasesUpgrade to a fixed version: Foglight 8.3.
Timeline
- CVE published1 day
- First seen by cve.now
Affected versions
- Quest Foglight for Databases
8.2.0
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-92186
Is CVE-2026-92186 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A directory traversal flaw in the paFnUploadFileAndCreateInfo function of Quest Foglight for Databases can let an attacker run code in the context of SYSTEM. The vulnerability is listed as a remote code execution issue.Source: zerodayinitiative.com
Which versions are affected by CVE-2026-92186?
Foglight for Databases: version 8.2.0.Source: cve.now feed data
Am I affected, and how do I check?
The advisory applies to affected installations of Quest Foglight for Databases, but the checked facts give no affected version range. To check an installation, look up its Foglight version in the product's about or version information and compare it with the fixed release, Foglight 8.3.Source: zerodayinitiative.com
How do I fix CVE-2026-92186?
Upgrade Foglight for Databases to version 8.3 or later, which is the fixed release. No workaround is listed in the checked facts.Source: zerodayinitiative.com