Unauthenticated Remote Code Execution via Auto-Login Bypass and Code Validation
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 1.10.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
IBM Langflow OSS is affected, allowing unauthenticated remote attackers to gain full control of the server and execute arbitrary code on default deployments. This could let an attacker take over the host system, access its data, and compromise connected resources.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
IBM Langflow OSS 1.0.0 through 1.10.0 allows unauthenticated attackers to chain /api/v1/auto_login (mints SUPERUSER tokens to any network caller) with /api/v1/validate/code (executes user code via exec()) to achieve full RCE on default Langflow deployments
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- IBM Langflow OSS
From 1.0.0 · through 1.10.0
References 1
ibm.com
Questions about CVE-2026-9198
What does this mean?
An unauthenticated attacker can send requests over the network to Langflow OSS and run arbitrary commands on the host system. The flaw combines an auto-login bypass that yields a superuser token with a code validation endpoint that executes attacker-supplied code.Source: ibm.com
Am I affected, and how do I check?
IBM lists Langflow OSS versions 1.0.0 through 1.10.0 as affected. The advisory says the issue affected all default deployments where the auto-login feature was enabled and the validation endpoint was network-accessible, so check the installed Langflow version and whether auto-login is enabled in its configuration.Source: ibm.com
What should I do about it?
Upgrade Langflow OSS to version 1.10.1, which contains the fix.Source: ibm.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-08-04, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data