Skip to main content
← Vulnerabilities

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Authorization in Handler for Custom URL Scheme…

Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected, and the fix is in 6.14.54.0 or later. CVSS rates it Low (3.5).

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

3.5LowCNA
Exploited
No known exploitation
Fix
Fixed in 6.14.54.0
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected

Published
Last modified
Published
Not listed in CISA KEV
12/100 · provisional
Specific setups only
Fix
Fixed in 6.14.54.0
None on Exploit-DB, Metasploit or GitHub

Summary

Dell Alienware Command Center, a utility for managing Alienware gaming hardware, is affected by this vulnerability. An attacker with low-level access could potentially exploit it remotely to forge requests from the user's system, which could lead to unauthorized actions being performed.

Read the original description

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Authorization in Handler for Custom URL Scheme vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Client-Side Request Forgery.

What to do

  • Check whether your setup matches what the bug needs.

    Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected
  • Upgrade to a fixed version: 6.14.54.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Dell Alienware Command Center (AWCC)

    fixed in 6.14.54.0

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-91901

What does this mean?

The handler for AWCC's custom URL scheme does not enforce proper authorization, which leads to Client-Side Request Forgery.Source: dell.com

Am I affected, and how do I check?

Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected. To check, look up the installed AWCC version number and compare it with 6.14.54.0.Source: dell.com

What should I do about it?

Upgrade AWCC to version 6.14.54.0 or later.Source: dell.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data