Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature…
Affects Dell Alienware Command Center (AWCC) versions before 6.14.54.0. CVSS rates it 6.4 (medium). Fixed in 6.14.54.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 6.14.54.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 12/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 6.14.54.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Dell Alienware Command Center, a utility for managing Alienware computers, is affected by a flaw in how it verifies cryptographic signatures. A user with high-level privileges on the local system could abuse this flaw to gain greater system control and run arbitrary code.
Read the original description
Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Verification of Cryptographic Signature vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of Privilege and Arbitrary Code Execution.
What to do
Check whether your setup matches what the bug needs.
Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected.Upgrade to a fixed version: 6.14.54.0.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Dell Alienware Command Center (AWCC)
fixed in 6.14.54.0
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-91899
What does this mean?
The software does not properly verify a cryptographic signature, which can let an attacker gain elevated privileges and run arbitrary code. The advisory describes the impact as elevation of privilege and arbitrary code execution.Source: dell.com
Am I affected, and how do I check?
Dell Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected. To check your installed version, look at the AWCC version shown in the application's settings or about screen.Source: dell.com
What should I do about it?
Upgrade Alienware Command Center to version 6.14.54.0 or later, which contains the fix.Source: dell.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data