Skip to main content
← Vulnerabilities

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Certificate Validation vulnerability.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

6.4MediumCNA
Exploited
No known exploitation
Fix
Fixed in 6.14.54.0
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected.

Published
Last modified
Published
Not listed in CISA KEV
11/100 · provisional
Specific setups only
Fix
Fixed in 6.14.54.0
None on Exploit-DB, Metasploit or GitHub

Summary

Dell Alienware Command Center (AWCC) fails to properly validate certificates, which could allow a local attacker with high privileges to run arbitrary code on the affected system and cause a denial of service.

Read the original description

Dell Alienware Command Center (AWCC), versions prior to 6.14.54.0, contain an Improper Certificate Validation vulnerability. A high privileged attacker with local access could potentially exploit this vulnerability, leading to Arbitrary Code Execution and Denial of Service.

What to do

  • Check whether your setup matches what the bug needs.

    Alienware Command Center (AWCC) versions prior to 6.14.54.0 are affected.
  • Upgrade to a fixed version: 6.14.54.0.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Dell Alienware Command Center (AWCC)

    fixed in 6.14.54.0

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-91897

What does this mean?

AWCC does not properly check the certificates it uses to verify a connection's identity. This weakness can lead to arbitrary code execution and denial of service.Source: dell.com

Am I affected, and how do I check?

All Alienware Command Center (AWCC) versions prior to 6.14.54.0 are listed as affected. To check a installed copy, look at its version number in the application's About information.Source: dell.com

What should I do about it?

Update Alienware Command Center to version 6.14.54.0 or later, which contains the fix.Source: dell.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data