Skip to main content
← Vulnerabilities

EWWW Image Optimizer 8.7.4 - 8.9.0 - Author+ Stored XSS via 'data-script' Lazy Load Attribute

Exploited
No known exploitation
Fix
Fixed in 8.9.1
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 8.9.1.

Published
Last modified
0.17% · 6th percentile
0/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

The EWWW Image Optimizer WordPress plugin before 8.9.1 does not properly sanitize and restrict a value in post content before using it to dynamically load and execute a script in the page, allowing authenticated attackers with author-level access and above to inject arbitrary web scripts that run in the session of any user who views the affected page, including administrators.

This is an incomplete fix of CVE-2026-15446: the origin and path restrictions added from 8.7.4 onward were each bypassable, so versions 8.7.4 through 8.9.0 remain affected.

cve.now Index

0Pcve.now Index 0 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity?/10Unknown. No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 55 if added to CISA KEV
  • Would score about 50 if CISA's SSVC rates exploitation active
  • Would score about 22 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 8.9.1.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Unknown EWWW Image Optimizer

    From 8.7.4 · fixed in 8.9.1

Evidence 1

  1. Exploit

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-91049

Is CVE-2026-91049 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-91049?

EWWW Image Optimizer: from 8.7.4 before 8.9.1.Source: cve.now feed data

How do I fix CVE-2026-91049?

Upgrade to a fixed version: 8.9.1.Source: cve.now feed data