Skip to main content
← Vulnerabilities

Apache OpenOffice: Out-of-bounds write when importing encrypted PDF files

Apache OpenOffice versions through 4.1.16 are affected when importing encrypted PDF files. The fix is in 4.1.17.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.3HighCISA-ADP
Exploited
No known exploitation
Fix
Fixed in 4.1.17
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Apache OpenOffice versions through 4.1.16 with the PDF import code

13Pcve.now Index 13 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure5/25Specific setups only
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.3/10CVSS 7.3, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 63 if added to CISA KEV
  • Would score about 58 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

CVE-2026-90634 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.3 (high) and affects Apache OpenOffice; fixed in 4.1.17.

Published
Last modified
Published
Not listed in CISA KEV
13/100 · provisional
Specific setups only
Fix
Fixed in 4.1.17
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Apache OpenOffice's PDF import code contains a bug that lets a specially crafted PDF file trigger an out-of-bounds memory write, which can crash the program or corrupt memory. The attacker reaches it by getting a user to open a crafted encrypted PDF in OpenOffice.

Read the original description

An uncontrolled memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 allows a crafted PDF to cause an out-of-bounds memory write, causing program crash or memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.

What to do

  • Check whether your setup matches what the bug needs.

    Apache OpenOffice versions through 4.1.16 with the PDF import code
  • Upgrade to a fixed version: 4.1.17.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Apache Software Foundation Apache OpenOffice

    through 4.1.16

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-90634

Is CVE-2026-90634 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An uncontrolled memory access in OpenOffice's PDF import code can write outside the memory it should. This can crash the program or corrupt memory.Source: openwall.com

Which versions are affected by CVE-2026-90634?

Apache OpenOffice: through 4.1.16.Source: cve.now feed data

Am I affected, and how do I check?

Apache OpenOffice versions through 4.1.16 with the PDF import code are affected. To check, look at the installed OpenOffice version number and compare it with 4.1.16.Source: openwall.com

How do I fix CVE-2026-90634?

Upgrade to Apache OpenOffice 4.1.17, which fixes this issue. No workaround is listed in the facts provided.Source: openwall.com