Apache OpenOffice: Out-of-bounds write when importing encrypted PDF files
Affects Apache OpenOffice through 4.1.16 when importing encrypted PDF files. Fixed in 4.1.17.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.1.17
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Apache OpenOffice through 4.1.16 Importing an encrypted PDF file
- Exploitation0/40No signal
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.3/10CVSS 7.3, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-90626 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.3 (high) and affects Apache OpenOffice; fixed in 4.1.17.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 4.1.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Apache OpenOffice's PDF import code can be crashed or have its memory corrupted by a specially crafted encrypted PDF file. An attacker would need to get a user to open such a file in the affected software.
Read the original description
An uncontrolled memory access in the PDF import code of Apache OpenOffice versions through 4.1.16 allows a crafted PDF to cause an out-of-bounds memory write, causing program crash or memory corruption. Users are recommended to upgrade to version 4.1.17, which fixes this issue.
What to do
Check whether your setup matches what the bug needs.
Apache OpenOffice through 4.1.16 Importing an encrypted PDF fileUpgrade to a fixed version: 4.1.17.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Apache Software Foundation Apache OpenOffice
through 4.1.16
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-90626
Is CVE-2026-90626 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A bug in how OpenOffice reads encrypted PDF files writes data outside the memory it should use. This can crash the program or corrupt memory.Source: openwall.com
Which versions are affected by CVE-2026-90626?
Apache OpenOffice: through 4.1.16.Source: cve.now feed data
Am I affected, and how do I check?
Apache OpenOffice versions through 4.1.16 are listed as affected, but only when importing an encrypted PDF file. To check your version, open the About dialog in OpenOffice or look at the version shown in its help menu.Source: openwall.com
How do I fix CVE-2026-90626?
Upgrade Apache OpenOffice to version 4.1.17, which fixes this issue, as the advisory recommends.Source: openwall.com