Missing server-side authorization in Eclipse Mnestix Browser admin server actions allows unauthenticated configuration tampering
Affects Eclipse Mnestix Browser versions 1.2.0 up to but excluding 2.3.0. No vendor severity rating is given, only CVSS 8.8 (high). Fixed in 2.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.3.0
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Affects Eclipse Mnestix Browser versions 1.2.0 up to but excluding 2.3.0.
- Exploitation0/40No signal
- Exposure15/25Specific setups only, CISA rates it automatable
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.8/10CVSS 8.8
- No patch0/5No signal
What would change the score
- Would score about 74 if added to CISA KEV
- Would score about 69 if CISA's SSVC rates exploitation active
CVE-2026-89293 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Eclipse Mnestix; fixed in 2.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.47% · 40th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 24/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Eclipse Mnestix Browser, a web application for viewing Asset Administration Shells, is affected. An unauthenticated attacker could perform administrator-only actions, such as changing infrastructure settings or triggering requests to the connected AAS Generator backend, potentially altering configuration without authorization.
Read the original description
In Eclipse Mnestix Browser versions 1.2.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker to perform actions that are only allowed to be executed by an authorized Mnestix user, like changing the Infrastructure settings or calling the connected and authenticated Mnestix AAS Generator backend.
What to do
Check whether your setup matches what the bug needs.
Affects Eclipse Mnestix Browser versions 1.2.0 up to but excluding 2.3.0.Upgrade to a fixed version: 2.3.0.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Eclipse Foundation Eclipse Mnestix
From 1.2.0 · fixed in 2.3.0
Evidence 2
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-89293
Is CVE-2026-89293 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Admin server actions in Eclipse Mnestix Browser do not check authorization on the server side, so an unauthenticated attacker can create, update, list and delete infrastructure records, including stored security headers and proxy credentials, and create connection records. This changes admin-only configuration.Source: gitlab.eclipse.org, gitlab.eclipse.org
Which versions are affected by CVE-2026-89293?
Eclipse Mnestix: from 1.2.0 before 2.3.0.Source: cve.now feed data
Am I affected, and how do I check?
Eclipse Mnestix Browser versions 1.2.0 up to but excluding 2.3.0 are in the affected range. To check an installation, compare the installed Mnestix Browser version against that range.Source: gitlab.eclipse.org, gitlab.eclipse.org
How do I fix CVE-2026-89293?
Upgrade Eclipse Mnestix Browser to 2.3.0 or later, which is the first version outside the affected range.Source: gitlab.eclipse.org, gitlab.eclipse.org