Unauthenticated SSRF with MNESTIX_BACKEND_API_KEY disclosure in Eclipse Mnestix Browser server actions for configured Infrastructures
Affects Eclipse Mnestix Browser 1.6.0 up to but excluding 2.3.0 in the documented quick-start deployment, where the Default Infrastructure entry is used. Fixed in 2.3.0.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.3.0
- Who is exposed
- Default setups
Do first: Check every install: default setups are affected.
- Exploitation0/40No signal
- Exposure25/25Default setups, CISA rates it automatable
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.2/10CVSS 9.2
- No patch0/5No signal
What would change the score
- Would score about 74 if added to CISA KEV
- Would score about 69 if CISA's SSVC rates exploitation active
CVE-2026-89292 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.2 (critical) and affects Eclipse Mnestix; fixed in 2.3.0.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.45% · 39th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 34/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Default setups
- Fix
- Fixed in 2.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Eclipse Mnestix Browser, a web application for viewing industrial asset data, is affected by this vulnerability. An unauthenticated attacker could use it to obtain the backend API key used for all configured Infrastructures, which could expose those backend systems to unauthorized access.
Read the original description
In Eclipse Mnestix Browser versions 1.6.0 up until but excluding 2.3.0 it was possible for an unauthenticated attacker to exfiltrate the MNESTIX_BACKEND_API_KEY for all configured Infrastructures.
What to do
Check every install: default setups are affected.
Upgrade to a fixed version: 2.3.0.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- Eclipse Foundation Eclipse Mnestix
From 1.6.0 · fixed in 2.3.0
Evidence 2
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-89292
Is CVE-2026-89292 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
Unauthenticated requests to the server actions can make the Mnestix server fetch arbitrary URLs, including internal and cloud metadata addresses, and read the responses (SSRF). The same flaw can also expose the MNESTIX_BACKEND_API_KEY backend API key.Source: gitlab.eclipse.org, gitlab.eclipse.org
Which versions are affected by CVE-2026-89292?
Eclipse Mnestix: from 1.6.0 before 2.3.0.Source: cve.now feed data
Am I affected, and how do I check?
The affected range is Eclipse Mnestix Browser 1.6.0 up to but excluding 2.3.0. The relevant setup is the documented quick-start deployment where the Default Infrastructure entry is used, so compare your installed Browser version and deployment setup against these conditions.Source: gitlab.eclipse.org, gitlab.eclipse.org
How do I fix CVE-2026-89292?
Upgrade Eclipse Mnestix Browser to 2.3.0, which is the listed fixed version. The sources give no workaround.Source: gitlab.eclipse.org, gitlab.eclipse.org