Rancher credentials disclosed to third-party hosts by the Rancher Manager meta proxy
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
- Who is exposed
- Default setups
Do first: Check every install: default setups are affected.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 45/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Default setups
- Fix
- Fixed in 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
SUSE Rancher Manager, specifically its meta proxy component, is affected by this vulnerability. A flaw in how the proxy filters requests could allow Rancher credentials to be sent to third-party cloud providers, exposing those credentials to unintended parties.
Read the original description
Missing filtering in the SUSE Rancher Manager meta proxy could cause passed in rancher credentials to be leaked to cloud providers. This affects SUSE Rancher 2.15.0 up to 2.15.3, 2.14.0 up to 2.14.7, 2.13.0 up to 2.13.11,
What to do
Check every install: default setups are affected.
Upgrade to a fixed version: 2.15.3, 2.14.7, 2.13.11, 2.12.15, 2.11.19.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
- Posted on X by cve.now
Affected versions
- Rancher
From 2.15.0 · fixed in 2.15.3; From 2.14.0 · fixed in 2.14.7; From 2.13.0 · fixed in 2.13.11; From 2.12.0 · fixed in 2.12.15; From 2.11.0 · fixed in 2.11.19
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-88811
What does this mean?
The Rancher Manager meta proxy, which the Rancher UI uses to query cloud provider APIs for a user, can forward requests to third-party hosts. When it does, the caller's Rancher credentials, either a browser session credential or an API token, are sent along with the request. The receiving party could then use that live credential with the affected user's permissions, which may include administrative access to Rancher Manager and managed clusters.Source: github.com
Am I affected, and how do I check?
Rancher Manager versions from 2.11.0 up to but not including 2.11.19, 2.12.0 to 2.12.15, 2.13.0 to 2.13.11, 2.14.0 to 2.14.7, and 2.15.0 to 2.15.3 are affected. To check a deployment, look up the Rancher Manager version it runs, for example in the Rancher UI or with the version command for the installed Rancher server.Source: github.com
What should I do about it?
Upgrade Rancher Manager to the fixed release for your branch: 2.15.3, 2.14.7, 2.13.11, 2.12.15, or 2.11.19.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data