Skip to main content
← Vulnerabilities

JupyterLab Desktop: One-Click Jupyter Server Token Leak leading to Remote Code Execution

Affects JupyterLab Desktop up to and including v4.2.5-1 when notebooks open in its default local session and JupyterLab in the environment is earlier than 4.4.8. Fixed in JupyterLab Desktop 4.6.2-1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.6CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 4.6.2-1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. JupyterLab Desktop up to and including v4.2.5-1 JupyterLab version in the environment earlier than 4.4.8 Notebook opened in a local session managed by JupyterLab Desktop

Published
Last modified
22/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

JupyterLab Desktop is the cross-platform desktop application for JupyterLab. Prior to 4.6.2-1, JupyterLab Desktop exposed getServerInfo to the renderer without confirming that the current page still had the local Jupyter server origin. In a local managed session using JupyterLab before 4.4.8, an attacker can place a crafted MathJax link in an untrusted notebook. If a victim opens the notebook and clicks the link, the existing renderer navigates to an attacker-controlled site while retaining access to the preload bridge. The site can call getServerInfo to obtain the local server URL and authentication token, then use the Jupyter REST API to create and trust a notebook that executes arbitrary code as the victim. Users whose environment already uses JupyterLab 4.4.8 or later are unaffected because the corrected link handling breaks the first step of the chain. This vulnerability is fixed in 4.6.2-1.

cve.now Index

22Pcve.now Index 22 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.6/10CVSS 9.6
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    JupyterLab Desktop up to and including v4.2.5-1 JupyterLab version in the environment earlier than 4.4.8 Notebook opened in a local session managed by JupyterLab Desktop
  • Upgrade to a fixed version: 4.6.2-1.

  • Workaround: Upgrade JupyterLab to 4.4.8 or later within the user's environment

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • jupyterlab jupyterlab-desktop

    fixed in 4.6.2-1

Evidence 3

  1. Advisory
  2. Repository
  3. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-86044

Is CVE-2026-86044 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The advisory describes a token leak in JupyterLab Desktop's one-click local Jupyter server. A malicious notebook could steal the local server URL and auth token, then create a trusted notebook to run code as the victim on their machine.Source: github.com

Which versions are affected by CVE-2026-86044?

jupyterlab-desktop: before 4.6.2-1.Source: cve.now feed data

Am I affected, and how do I check?

Affected are JupyterLab Desktop up to and including v4.2.5-1, with a JupyterLab version earlier than 4.4.8 in the environment, when notebooks are opened in the default local session that JupyterLab Desktop manages. To check, look at the JupyterLab Desktop version in the app's About information and run jupyter lab --version in the environment.Source: github.com

How do I fix CVE-2026-86044?

Upgrade JupyterLab Desktop to 4.6.2-1, which the advisory says all users should do. The advisory's workaround is to upgrade JupyterLab to 4.4.8 or later within the environment.Source: github.com