Skip to main content
← Vulnerabilities

IBM Watson Speech Services Cartridge is vulnerable to a Use After Free condition in cryptography wheels OpenSSL

Affects IBM Watson Speech Services Cartridge versions 4.0.0 through 5.4.0 via the OpenSSL bundled in cryptography wheels before 48.01. Fixed in 5.4.0 Patch 8.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.8CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 5.4.0 Patch 8
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.4.0 Patch 8.

27Pcve.now Index 27 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.8/10CVSS 9.8
  • No patch0/5No signal

What would change the score

  • Would score about 72 if added to CISA KEV
  • Would score about 67 if CISA's SSVC rates exploitation active
  • Would score about 32 if advisories confirm default setups are exposed

CVE-2026-82418 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.8 (critical) and affects Watson Speech Services Cartridge; fixed in 5.4.0 Patch 8.

Published
Last modified
Published
Not listed in CISA KEV
27/100 · provisional
Unclear
Fix
Fixed in 5.4.0 Patch 8
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

IBM Watson Speech Services Cartridge is affected by a use-after-free flaw in its bundled cryptography wheels OpenSSL component. A remote attacker without logging in could exploit it over the network to execute arbitrary code.

Read the original description

IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0 could allow a remote attacker to execute arbitrary code due to a use-after-free vulnerability.

What to do

  • Upgrade to a fixed version: 5.4.0 Patch 8.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now

Affected versions

  • IBM Watson Speech Services Cartridge

    From 4.0.0 · through 5.4.0

Evidence 1

  1. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-82418

Is CVE-2026-82418 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is a use-after-free bug in the OpenSSL copy included in cryptography wheels, triggered during PKCS#7 signature verification. Use-after-free means memory is used after it has been released, and the advisory says this could allow a remote attacker to execute arbitrary code.Source: ibm.com

Which versions are affected by CVE-2026-82418?

Watson Speech Services Cartridge: from 4.0.0 through 5.4.0.Source: cve.now feed data

Am I affected, and how do I check?

The product versions listed are IBM Watson Speech Services Cartridge 4.0.0 through 5.4.0. The vulnerable component is the OpenSSL version included in cryptography wheels prior to 48.01, so the cryptography package version in the cartridge environment is the thing to check.Source: ibm.com

How do I fix CVE-2026-82418?

Upgrade to 5.4.0 Patch 8, which the vendor says fixes all versions listed from 4.0.0 to 5.4.0.Source: ibm.com