Skip to main content
← Vulnerabilities

Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation…

Affects Dell Wyse Management Suite versions prior to 2609.0.0.155. Fixed in 2609.0.0.155. No vendor rating was given, so the CVSS score of 8.8 (High) is the only severity figure.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 2609.0.0.155
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Dell Wyse Management Suite versions prior to 2609.0.0.155

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.8/10CVSS 8.8
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-82159 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects Wyse Management Suite; fixed in 2609.0.0.155.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in 2609.0.0.155
None on Exploit-DB, Metasploit or GitHub

Summary

Dell Wyse Management Suite, a tool for managing thin client devices, is affected by a cross-site scripting flaw that lets a low-privileged remote attacker inject malicious scripts into its web pages. Successful exploitation could allow those scripts to run in users' browsers within the application.

Read the original description

Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection.

What to do

  • Check whether your setup matches what the bug needs.

    Dell Wyse Management Suite versions prior to 2609.0.0.155
  • Upgrade to a fixed version: 2609.0.0.155.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Dell Wyse Management Suite

    fixed in 2609.0.0.155

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-82159

Is CVE-2026-82159 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is an improper neutralization of input during web page generation, which allows script injection into the Dell Wyse Management Suite web interface. Injected script would run within the web interface.Source: dell.com

Which versions are affected by CVE-2026-82159?

Wyse Management Suite: before 2609.0.0.155.Source: cve.now feed data

Am I affected, and how do I check?

Dell Wyse Management Suite versions prior to 2609.0.0.155 are affected. To check your version, look at the product version shown in the management console or the installed version in the server's software information.Source: dell.com

How do I fix CVE-2026-82159?

Upgrade Dell Wyse Management Suite to version 2609.0.0.155 or later, which contains the fix.Source: dell.com