Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation…
Dell Wyse Management Suite versions prior to 2609.0.0.155 are covered by this advisory. The fix is in version 2609.0.0.155.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2609.0.0.155
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Dell Wyse Management Suite versions prior to 2609.0.0.155
- Exploitation0/40No signal
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity10/10CVSS 9.0, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 68 if added to CISA KEV
- Would score about 63 if CISA's SSVC rates exploitation active
- Would score about 25 if CISA's SSVC rates it automatable
CVE-2026-82158 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.0 (critical) and affects Wyse Management Suite; fixed in 2609.0.0.155.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 18/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2609.0.0.155
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Dell Wyse Management Suite, a centralized management platform for thin clients, is affected by a cross-site scripting flaw that lets a low-privileged remote attacker inject malicious scripts into its web pages. Successful exploitation could allow the attacker to run unauthorized scripts in users' browsers within the application.
Read the original description
Dell Wyse Management Suite, versions prior to 2609.0.0.155, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection.
What to do
Check whether your setup matches what the bug needs.
Dell Wyse Management Suite versions prior to 2609.0.0.155Upgrade to a fixed version: 2609.0.0.155.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Dell Wyse Management Suite
fixed in 2609.0.0.155
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-82158
Is CVE-2026-82158 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The flaw is an improper neutralization of input during web page generation, which leads to script injection into the web interface (cross-site scripting).Source: dell.com
Which versions are affected by CVE-2026-82158?
Wyse Management Suite: before 2609.0.0.155.Source: cve.now feed data
Am I affected, and how do I check?
Dell Wyse Management Suite versions prior to 2609.0.0.155 are in the affected range. Compare the installed Wyse Management Suite version with 2609.0.0.155 to see whether it falls below that version.Source: dell.com
How do I fix CVE-2026-82158?
Upgrade Dell Wyse Management Suite to version 2609.0.0.155 or later. No workaround is listed in the checked facts.Source: dell.com