Dell OS Recovery tool versions, prior to 2.4.4, contain a use of Untrusted Search Path vulnerability.
Dell OS Recovery Tool versions before 2.4.4 are affected. The fix is in version 2.4.4 and later.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.4.4
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Dell OS Recovery Tool versions prior to 2.4.4 are affected
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.8/10CVSS 7.8
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
CVE-2026-82155 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.8 (high) and affects OS Recovery tool; fixed in 2.4.4.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.4.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Dell OS Recovery tool, an application used to recover operating systems on Dell devices, is affected by this vulnerability. A local attacker without credentials could potentially exploit it to run arbitrary commands on the system.
Read the original description
Dell OS Recovery tool versions, prior to 2.4.4, contain a use of Untrusted Search Path vulnerability. An unauthenticated attacker with local access could potentially exploit this vulnerability, leading to Command execution.
What to do
Check whether your setup matches what the bug needs.
Dell OS Recovery Tool versions prior to 2.4.4 are affectedUpgrade to a fixed version: 2.4.4.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Dell OS Recovery tool
fixed in 2.4.4
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-82155
Is CVE-2026-82155 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The tool uses an untrusted search path, so it can load code from a location an attacker may influence. This can lead to command execution on the affected system.Source: dell.com
Which versions are affected by CVE-2026-82155?
OS Recovery tool: before 2.4.4.Source: cve.now feed data
Am I affected, and how do I check?
Dell OS Recovery Tool versions prior to 2.4.4 are affected. To check, compare the installed version of the tool with 2.4.4.Source: dell.com
How do I fix CVE-2026-82155?
Update the Dell OS Recovery Tool to version 2.4.4 or later, which contains the fix.Source: dell.com