Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.16 OS Command Injection via /newpass/

Affects Control Web Panel (CWP) versions before 1.16, where the flaw is an OS command injection in the /newpass/ path. Fixed in 1.16.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.16
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Control Web Panel (CWP) version before 1.16

Published
Last modified
Published
Not listed in CISA KEV
14/100 · provisional
Specific setups only
Fix
Fixed in 1.16
None on Exploit-DB, Metasploit or GitHub

Summary

Control Web Panel (CWP), a web hosting control panel for managing Linux servers, is affected by this flaw in its password change functionality. An attacker who can send crafted requests to it can run arbitrary operating system commands with root privileges, giving them full control of the server.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.16 contains an OS command injection vulnerability in the loopback API password change route /newpass/, which runs as root. An attacker can inject arbitrary OS commands by manipulating the POST 'user' parameter that is passed unescaped into a shell command, achieving remote code execution with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    Control Web Panel (CWP) version before 1.16
  • Upgrade to a fixed version: 1.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.16

Evidence 3

  1. Patch
  2. Exploit
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-77880

What does this mean?

The /newpass/ feature of Control Web Panel passes input to the operating system without proper checks, so commands can be run on the server. The advisory says this gives remote code execution with root privileges.Source: vulncheck.com

Am I affected, and how do I check?

Control Web Panel versions before 1.16 are affected. To check an install, look at the webpanel_version value the panel reports, which is listed as 1.16 in the fixed release.Source: vulncheck.com

What should I do about it?

Upgrade Control Web Panel to version 1.16 or later, which is the fixed version listed for this issue.Source: vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data