Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.16 OS Command Injection via protected_directory

Affects Control Web Panel (CWP) before 1.16 through the protected_directory user panel module. Fixed in 1.16.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.3CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 1.16
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 1.16.

Published
Last modified
Published
Not listed in CISA KEV
16/100 · provisional
Unclear
Fix
Fixed in 1.16
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post

Summary

Control Web Panel (CWP), a web hosting control panel, is affected, specifically its protected directory feature in the user panel. An attacker who can reach this feature could run arbitrary operating system commands, gaining code execution in the user panel context.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.16 contains an OS command injection vulnerability in the protected_directory user panel module that allows attackers to execute arbitrary commands by submitting unescaped input through the file POST parameter in the acc=deletedp action. Attackers can exploit this flaw, which passes attacker-controlled input directly into a shell_exec call, to achieve code execution in the user panel context.

What to do

  • Upgrade to a fixed version: 1.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated
  4. Posted on X by cve.now

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.16

Evidence 3

  1. Patch
  2. Exploit
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-77876

What does this mean?

Unescaped input sent through the file POST parameter of the protected_directory module is passed to the operating system as a command. This lets an attacker run arbitrary OS commands and execute code in the user panel context.Source: vulncheck.com

Am I affected, and how do I check?

Control Web Panel versions before 1.16 are affected. To check, look at the webpanel_version value in your installation. The issue is in the protected_directory user panel module's acc=deletedp action, which takes the file POST parameter.Source: vulncheck.com

What should I do about it?

Upgrade Control Web Panel to version 1.16 or later, which contains the fix.Source: vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data