Skip to main content
← Vulnerabilities

Catalyst::Plugin::Authentication versions before 0.10029 for Perl allow timing attacks on stored passwords via eq comparisons in the…

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

—Not rated
Exploited
No known exploitation
Fix
Fixed in 0.10029
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 0.10029.

0Pcve.now Index 0 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure?/25Exposure: unknown (data gap). No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity?/10Severity: unknown (data gap). No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 55 if added to CISA KEV
  • Would score about 50 if CISA's SSVC rates exploitation active
  • Would score about 22 if advisories confirm default setups are exposed

CVE-2026-74846 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It affects Catalyst-Plugin-Authentication; fixed in 0.10029.

Published
Last modified
Published
Not listed in CISA KEV
0.27% · 19th percentile
0/100 · provisional
Fix
Fixed in 0.10029
None on Exploit-DB, Metasploit or GitHub

Summary

Catalyst::Plugin::Authentication for Perl, in versions before the fixed release, is affected through its legacy password verifier used by the deprecated login method. Because stored passwords and hashes are compared in a way that takes longer the more leading characters match, a remote attacker could measure response-time differences to gradually guess a user's password or hash.

Read the original description

Catalyst::Plugin::Authentication versions before 0.10029 for Perl allow timing attacks on stored passwords via eq comparisons in the legacy password verifier. CVE-2026-5091 was fixed in the realm-based verifier. The legacy verifier, used by the deprecated login method, compares clear-text passwords, crypt hashes and base64 digests with eq, so the comparison time depends on how many leading bytes match. A remote attacker can use response-time differences to guess the stored password or hash.

What to do

  • Upgrade to a fixed version: 0.10029.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Catalyst-Plugin-Authentication

    fixed in 0.10029

Evidence 3

  1. Patch
  2. Link
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-74846

Is CVE-2026-74846 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-74846?

Catalyst-Plugin-Authentication: before 0.10029.Source: cve.now feed data

How do I fix CVE-2026-74846?

Upgrade to a fixed version: 0.10029.Source: cve.now feed data