Skip to main content
← All vulnerabilities
CVE-2026-72898

Metabase SQL injection via password reset endpoint

Affects self-hosted Metabase 0.58.0 through 0.63.x before the listed patch releases; Metabase Cloud is already patched. Fixed in 0.58.24, 0.59.21, 0.60.17, 0.61.11, 0.62.9 and 0.63.5.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in x.58.24, x.59.21, x.60.17, x.61.11, x.62.9, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

Metabase, a business intelligence and analytics platform, is affected by this vulnerability. A remote attacker without any login can exploit a flaw in its password reset endpoint to run arbitrary SQL commands and gain administrator access to the Metabase instance.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Metabase allows a remote, unauthenticated attacker to inject arbitrary SQL via the '/reset_password' database endpoint and gain administrator access to the connected Metabase instance.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. Record last updated
  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Metabase Metabase

    From x.58.0 · fixed in x.58.24; From x.59.0 · fixed in x.59.21; From x.60.0 · fixed in x.60.17; From x.61.0 · fixed in x.61.11; From x.62.0 · fixed in x.62.9; From x.63.0 · fixed in x.63.5

References 4

GitHub · metabase/metabase

metabase.com

cve.org

raw.githubusercontent.com

FAQ

Questions about CVE-2026-72898

What does this mean?

The password reset endpoint does not properly handle input, so an unauthenticated attacker can inject arbitrary SQL into the Metabase application database. The advisory says this can give the attacker administrator access to the instance.Source: github.com, metabase.com

Am I affected, and how do I check?

Metabase versions from 0.58.0 up to but not including 0.58.24, 0.59.0 to before 0.59.21, 0.60.0 to before 0.60.17, 0.61.0 to before 0.61.11, 0.62.0 to before 0.62.9, and 0.63.0 to before 0.63.5. Only self-hosted instances with the /api/session/reset_password endpoint publicly reachable are listed as at risk; Metabase Cloud is already patched.Source: github.com, metabase.com

What should I do about it?

Upgrade to the patch release for your Metabase major version: 0.58.24, 0.59.21, 0.60.17, 0.61.11, 0.62.9, or 0.63.5 or later. The advisory says to do this as soon as possible.Source: github.com, metabase.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-08-11, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data