Skip to main content
← Vulnerabilities

SuiteCRM: SQL injection via search param in modules/Cases/controller.php

Affects SuiteCRM 7.15.1 and earlier, and 8.10.1 and earlier, for authenticated users with access to the Cases module. Fixed in 7.15.2 and 8.10.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.3HighCNA
Exploited
No known exploitation
Fix
Fixed in 7.15.2, 8.10.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. SuiteCRM affected versions are 7.15.1 and earlier, and 8.10.1 and earlier The attacker needs access to the Cases module

Published
Last modified
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the CasesController action_get_kb_articles action interpolates $_POST['search'] into a CASE WHEN ... LIKE expression and the SQL WHERE clause. Although securexss() normally entity-encodes quotes, an input prefixed with an XSS payload makes AntiXSS select a processed string instead of the encoded backup, allowing a literal quote to reach the query. A low-privileged user with Cases module access can perform blind SQL injection and extract sensitive database information. This issue is fixed in versions 7.15.2 and 8.10.2.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity8.3/10CVSS 8.3
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    SuiteCRM affected versions are 7.15.1 and earlier, and 8.10.1 and earlier The attacker needs access to the Cases module
  • Upgrade to a fixed version: 7.15.2, 8.10.2.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • SuiteCRM SuiteCRM

    fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2

Evidence 6

  1. Advisory
  2. Advisory
  3. Repository
  4. Repository
  5. Repository
  6. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-69141

Is CVE-2026-69141 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The search parameter in modules/Cases/controller.php is not properly sanitized before it is used in a database query, which is a SQL injection flaw. Using time-based blind SQL injection, a user can extract sensitive data from any database table.Source: github.com

Which versions are affected by CVE-2026-69141?

SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data

Am I affected, and how do I check?

SuiteCRM versions 7.15.1 and earlier, and 8.10.1 and earlier, are affected. The attacker needs to be an authenticated low-privilege user with access to the Cases module. To check a installation, compare its installed SuiteCRM version against these version numbers.Source: github.com

How do I fix CVE-2026-69141?

Upgrade to SuiteCRM 7.15.2 if you run the 7.x line, or to 8.10.2 if you run the 8.x line. These are the patched versions named in the advisory.Source: github.com