WordPress WordPress File Upload plugin <= 5.2.1 - Cross Site Scripting (XSS) vulnerability
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 39/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 5.2.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The WordPress File Upload plugin by Nickboss, used to let site visitors upload files through WordPress websites, is affected by a stored cross-site scripting flaw. An attacker could exploit this to inject malicious scripts that run in the browsers of other users who view the affected pages, potentially allowing session hijacking or actions taken on their behalf.
Read the original description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nickboss WordPress File Upload wp-file-upload allows Stored XSS.This issue affects WordPress File Upload: from n/a through 5.2.1.
What to do
Check whether your setup matches what the bug needs.
WordPress File Upload plugin version 5.2.1 or earlierUpgrade to a fixed version: 5.2.2.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- wp-file-upload
through 5.2.1
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-66570
What does this mean?
The plugin fails to properly sanitize some input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com
Am I affected, and how do I check?
WordPress File Upload plugin version 5.2.1 and earlier, by Nickboss, is affected. To check, look at the plugin version shown on the installed plugins page in the WordPress admin area.Source: patchstack.com
What should I do about it?
Update the WordPress File Upload plugin to version 5.2.2 or later, which contains the fix.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data