WordPress AI Engine plugin <= 3.8.8 - Cross Site Request Forgery (CSRF) vulnerability
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 3.8.9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The AI Engine plugin for WordPress, made by Meow Apps, is affected by this flaw. An attacker could trick a logged-in site administrator into unknowingly performing actions on the website, such as changing settings, because the plugin does not properly verify that requests come from the site's own users.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Cross-Site Request Forgery (CSRF) vulnerability in Meow Apps AI Engine ai-engine allows Cross Site Request Forgery.This issue affects AI Engine: from n/a through 3.8.8.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- ai-engine
through 3.8.8
References 1
Questions about CVE-2026-65566
What does this mean?
Logged-in users of the AI Engine plugin can be tricked into performing actions they did not intend, such as changing passwords or making purchases. The flaw is a Cross Site Request Forgery (CSRF) issue, meaning a malicious page can cause a logged-in browser to send requests the user did not mean to make.Source: patchstack.com
Am I affected, and how do I check?
Versions of the AI Engine plugin for WordPress up to and including 3.8.8 are affected, from the earliest release through 3.8.8. To check, look at the plugin version shown on the WordPress Plugins screen or in the plugin's header in the installed files.Source: patchstack.com
What should I do about it?
Update the AI Engine plugin to version 3.8.9 or later, which the source says fixes the issue.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data