Skip to main content
← All vulnerabilities
CVE-2026-64391

ksmbd: use opener credentials for ADS I/O

The Linux kernel ksmbd server's alternate data stream reads and writes are affected in versions from 5.15.0 up to the fixed releases 6.6.160, 6.12.96, 6.18.39, and 7.1.4. CVSS rates it 9.8 (critical).

Published
Last modified
published
Not listed in CISA KEV
Unclear
Fix
Fixed in 6.6.160, 6.12.96, 6.18.39, 7.1.4
None on Exploit-DB, Metasploit or GitHub

Summary

The ksmbd in-kernel SMB server component of the Linux kernel is affected. Reads and writes to alternate data streams could be checked against the credentials of the current task instead of those captured when the file handle was opened, which may lead to incorrect permission and security policy enforcement.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

In the Linux kernel, the following vulnerability has been resolved: ksmbd: use opener credentials for ADS I/O Alternate data streams are stored as xattrs. Unlike regular file I/O, their read and write paths therefore call VFS xattr helpers which recheck inode permissions and LSM policy using the current task credentials. Run ADS I/O with the credentials captured when the SMB handle was opened.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Linux Linux

    Version range not reported

  • Linux Linux

    5.15

  • KernelLinux

    From 5.15.0 · fixed in 6.6.160; From 6.7.0 · fixed in 6.12.96; From 6.13.0 · fixed in 6.18.39; From 6.19.0 · fixed in 7.1.4

References 6

git.kernel.org

FAQ

Questions about CVE-2026-64391

What does this mean?

The bug concerns how ksmbd, the kernel's SMB file server, reads and writes alternate data streams (ADS). The fix makes these operations use the credentials of the account that opened the file. ADS are stored as xattrs.Source: git.kernel.org

Am I affected, and how do I check?

Kernel versions from 5.15.0 up to but not including 6.6.160, 6.7.0 up to 6.12.96, 6.13.0 up to 6.18.39, and 6.19.0 up to 7.1.4 are listed as affected. To check a system, run uname -r and compare the result with these ranges, and confirm whether ksmbd is in use.Source: git.kernel.org

What should I do about it?

Upgrade to the fixed kernel for your release series: 6.6.160, 6.12.96, 6.18.39, or 7.1.4 or later.Source: git.kernel.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data