Skip to main content
← Vulnerabilities

Yeti: Path traversal in DFIQ uuid allows authenticated arbitrary file write during archive export

Affects YETI versions up to and including 2.5.0, where a valid non-admin authenticated account that can import DFIQ YAML and trigger archive export is enough to write files outside the temporary directory.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
No fix listed
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Attacker must have a valid authenticated account on YETI (non-admin is sufficient) that can import DFIQ YAML and trigger DFIQ archive export. The YETI service account has write permissions on the targeted path.

20Pcve.now Index 20 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch5/5No patch listed yet

What would change the score

  • Would score about 70 if added to CISA KEV
  • Would score about 65 if CISA's SSVC rates exploitation active
  • Would score about 27 if CISA's SSVC rates it automatable

CVE-2026-63500 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects yeti; no fixed version is listed yet.

Published
Last modified
Published
Not listed in CISA KEV
20/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Yeti, a Forensics Intelligence platform used by CTI and DFIR practitioners, is affected by a path traversal flaw in its DFIQ import and archive export features. An authenticated low-privileged user can cause attacker-controlled YAML content to be written to arbitrary locations within the paths the Yeti service account can write to.

Read the original description

Yeti bridges the gap between CTI and DFIR practitioners by providing a Forensics Intelligence platform and pipeline. Prior to 2.5.1, core/schemas/dfiq.py accepts an unvalidated uuid from DFIQ YAML through POST /api/v2/dfiq/from_yaml, and core/web/apiv2/dfiq.py later interpolates that stored value into an archive filesystem path in POST /api/v2/dfiq/to_archive. A low-privileged authenticated user can import a DFIQ object whose UUID contains traversal sequences and trigger archive export, causing attacker-controlled content with a .yaml suffix to be written outside the intended temporary archive directory. The impact is limited by paths writable by the YETI service account, and the separate DFIQ archive-import zip-slip candidate is not part of this vulnerability. This issue is fixed in version 2.5.1.

What to do

  • Check whether your setup matches what the bug needs.

    Attacker must have a valid authenticated account on YETI (non-admin is sufficient) that can import DFIQ YAML and trigger DFIQ archive export. The YETI service account has write permissions on the targeted path.
  • Workaround: Limit which accounts can import DFIQ YAML and trigger archive export. Restrict the YETI service account's write permissions to only the paths it needs.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • yeti-platform yeti

    through 2.5.0

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-63500

Is CVE-2026-63500 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A low-privileged authenticated user can make YETI write a .yaml file with attacker-controlled content outside the intended archive temporary directory. This can overwrite writable files or corrupt data.Source: github.com

Which versions are affected by CVE-2026-63500?

yeti: through 2.5.0.Source: cve.now feed data

Am I affected, and how do I check?

Versions up to and including 2.5.0 of the yeti product from yeti-platform. Exposure also depends on a valid authenticated account that can import DFIQ YAML and trigger DFIQ archive export, and on the YETI service account having write permission on the target path. Compare the installed YETI version with 2.5.0 and review the service account's write permissions.Source: github.com

How do I fix CVE-2026-63500?

The facts list no fixed version, so no upgrade target is confirmed. Check the vendor's advisory for a fix and update to it when one is released.Source: github.com

What if there's no patch?

Limit which accounts can import DFIQ YAML and trigger archive export. Restrict the YETI service account's write permissions to only the paths it needs.Source: github.com