Skip to main content
← Vulnerabilities

Yeti: Unauthenticated Access to Full Audit Timeline Discloses All Threat Intelligence Data

Yeti versions before 2.5.1 register the audit timeline endpoint /api/v2/audit/timeline/{id} without an authentication dependency. Fixed in 2.5.1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.5HighCNA
Exploited
No known exploitation
Fix
Fixed in 2.5.1
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 2.5.1.

28Pcve.now Index 28 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure20/25No login or user action needed, CISA rates it automatable · Data gap: Advisories don't say whether default setups are affected
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.5/10CVSS 7.5
  • No patch0/5No signal

What would change the score

  • Would score about 73 if added to CISA KEV
  • Would score about 68 if CISA's SSVC rates exploitation active
  • Would score about 33 if advisories confirm default setups are exposed

CVE-2026-63482 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.5 (high) and affects yeti; fixed in 2.5.1.

Published
Last modified
Published
Not listed in CISA KEV
28/100 · provisional
Unclear
Fix
Fixed in 2.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Yeti, a threat intelligence and forensics platform, has an API audit endpoint that does not require login, so anyone on the network can read its full audit history. This exposes sensitive details such as analyst usernames, threat intelligence object values, and before-and-after data for those objects.

Read the original description

Yeti bridges the gap between CTI and DFIR practitioners by providing a Forensics Intelligence platform and pipeline. Prior to 2.5.1, YETI registers the audit router without Depends(auth.get_current_active_user), and core/web/apiv2/audit.py does not perform a route-level authentication check for /api/v2/audit/timeline/{id}. An unauthenticated network attacker can use an empty, partial, or specific wildcard path to query TimelineLog records containing the actor, target_id, action, and details fields, including analyst usernames, object identifiers and values, and before-and-after object data. This exposes the operational history of threat-intelligence objects while other application routers require authentication. This issue is fixed in version 2.5.1.

What to do

  • Upgrade to a fixed version: 2.5.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  4. Record last updated

Affected versions

  • yeti-platform yeti

    fixed in 2.5.1

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-63482

Is CVE-2026-63482 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The audit timeline endpoint can be read without logging in. Anyone who reaches it can see the full audit trail of threat intelligence objects, including analyst usernames, object values, and before/after details.Source: github.com

Which versions are affected by CVE-2026-63482?

yeti: before 2.5.1.Source: cve.now feed data

Am I affected, and how do I check?

The flaw is in Yeti versions before 2.5.1, where the audit router at /api/v2/audit/timeline/{id} has no authentication dependency. To check a installation, a reader can confirm the Yeti version and whether that endpoint returns data without credentials.Source: github.com

How do I fix CVE-2026-63482?

Upgrade Yeti to version 2.5.1 or later, which is the fixed release.Source: github.com