OpenSearch SQL plugin: Unsafe cursor deserialization permits server code execution
Affects the OpenSearch SQL plugin from 2.8.0.0 to 2.19.6.0 and from 3.0.0-alpha1 to 3.7.0.0, reached through the plugins/sql endpoint. Fixed in 2.19.6 and 3.7.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.19.6.0, 3.7.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The OpenSearch SQL plugin, which lets users query OpenSearch data with SQL and Piped Processing Language, is affected. An authenticated user with basic read or search permissions can send a crafted cursor parameter that causes the server to unsafely deserialize untrusted data, allowing them to run arbitrary code on the server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted `cursor` parameter to the `plugins/sql` endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- opensearch-project sql
From 2.8.0.0 · fixed in 2.19.6.0; From 3.0.0.0-alpha1 · fixed in 3.7.0.0
References 7
Questions about CVE-2026-63393
What does this mean?
The plugin deserializes the cursor parameter sent to the plugins/sql endpoint without proper checks. A crafted cursor value can make the server run arbitrary code.Source: github.com
Am I affected, and how do I check?
The OpenSearch SQL plugin in versions 2.8 through 3.6 is affected: 2.x from 2.8.0.0 until 2.19.6.0, and 3.x before 3.7.0.0. To check, look at the installed SQL plugin version on the cluster, and note whether the plugins/sql endpoint accepts cursor parameters.Source: github.com
What should I do about it?
Upgrade the SQL plugin to 2.19.6 or later on the 2.x line, or to 3.7 or later on the 3.x line. The advisory states the issue is addressed in OpenSearch 3.7 and 2.19.6.Source: github.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data