SuiteCRM: Authenticated SQL Injection in v4_1 get_entry_list rest api
Affects SuiteCRM before 7.15.2 and 8.0.0 through 8.10.2, for accounts with a valid login and list permission on at least one module. Fixed in 7.15.2 and 8.10.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.15.2, 8.10.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Attacker has a valid SuiteCRM user account The account has list ACL permission on at least one module
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
SuiteCRM, an open-source customer relationship management application, has an SQL injection flaw in its legacy v4_1 REST API (get_entry_list) that lets a logged-in user with list permission on a module read database contents, including password hashes and other data. The bug can be reached remotely over the network, and it requires only low-privilege login with no user interaction.
Read the original description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, legacy REST methods append an authenticated caller's query parameter as a SQL WHERE clause after insufficient structural validation. The affected flow begins at /service/v4_1/rest.php and uses get_entry_list, get_entries_count, and query to carry attacker-controlled data or authorization state into the security-sensitive operation. An account with list permission on a module can bypass the user_hash filter, retrieve password hashes and other database data, and use recovered administrative credentials to compromise the application. This issue is fixed in versions 7.15.2 and 8.10.2.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.8/10CVSS 8.8
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
Attacker has a valid SuiteCRM user account The account has list ACL permission on at least one moduleUpgrade to a fixed version: 7.15.2, 8.10.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- SuiteCRM SuiteCRM
fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-63214
Is CVE-2026-63214 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The v4_1 get_entry_list REST API has a SQL injection flaw in its user_hash filter. An logged-in user with minimal privileges can use it to read password hashes of other users, including the administrator's, which can lead to full control of the platform.Source: github.com
Which versions are affected by CVE-2026-63214?
SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data
Am I affected, and how do I check?
SuiteCRM versions before 7.15.2 and versions 8.0.0 through 8.10.2 are in the affected ranges. The flaw needs a valid SuiteCRM account that has list ACL permission on at least one module. Compare your installed SuiteCRM version against these ranges.Source: github.com
How do I fix CVE-2026-63214?
Upgrade to SuiteCRM 7.15.2 if you run the 7.x line, or to 8.10.2 if you run the 8.x line. The advisory lists no workaround.Source: github.com